Chevy and GMC Duramax Diesel Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Trying to figure out what’s causing the sound of my heater fan surging during acceleration even though fan is off ? The low coolant warning has also come on a couple times and it’s not low. It’s a 2011 LML.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Are you sure it isn’t the engine coolant fan that you’re hearing?
Not sure. Can’t replicate the sound with hood open. It only started doing it about a week ago and I’ve had the truck since new and have never heard this sound before. It’s also odd that the
“low coolant “ comes on when it’s full and not overheating 🤔. The sound in the cab is exactly like the heater fan has been turned to high speed and stops the moment I let off the fuel or when I get up to speed.
 

·
Premium Member
Joined
·
337 Posts
Definitely sounds like the engine cooling fan. Low coolant message is most likely a separate issue altogether.
 

·
Premium Member
Joined
·
352 Posts
Maybe the engine fan is locked up. They really roar when they are. Look at the fan when you first start it when cold. Fan will turn but is just loafing along versus really moving even at idle if it is locked
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Definitely sounds like the engine cooling fan. Low coolant message is most likely a separate issue altogether.
I thank you for taking the time to reply. I actually just dropped it off at a shop because well it’s not going to fix itself 😂. I’m thinking your probably right because there is not much else that could make that sound. Perhaps the fan clutch 🤔. Will let you know. Thanks again 😊
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
I thank you for taking the time to reply. I actually just dropped it off at a shop because well it’s not going to fix itself 😂. I’m thinking your probably right because there is not much else that could make that sound. Perhaps the fan clutch 🤔. Will let you know. Thanks again 😊
The problem turned out to be a leak from the up pipe. 10.5 hrs labor. While the cab was off I had them replace the down pipe also 😂. I’m very much liking the new sound and the faster response of the turbo 😃
 

·
Premium Member
Joined
·
352 Posts
Glad they got you fixed. Would have thought the labor would have been a lot more to remove the cab and reinstall it
 
1 - 8 of 8 Posts
Top