Chevy and GMC Duramax Diesel Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
178 Posts
Discussion Starter #1
So I just got done installing a high idle switch in my truck, fired it up to test it and noticed the idle acting strange, almost surging. This was with the high idle engaged and the engine idling around 850RPM. In the begging of the video I turned the high idle off and the surging sound goes away. I'm not sure if this is normal, or if I have an issue starting to show itself?

Also, at the end of the video I walk up to engine bay, are everybody else's engines this clattery? I've got 230K on the truck and about 10K on a set of new injectors from LDS.

 

·
Registered
Joined
·
267 Posts
Did your LLY not come with a high idle from the factory? My factory high idle brings RPM to about 1200. Are you able to change yours to that? It might just be 850 RPM is not a good one to set the idle to. I also don't think 850 is going to help it heat up much. The engine needs to be under some load to generate heat, not sure 850 is enough of a load.

Do you have a factory exhaust? Mine sounds nothing close to that raspy, it's more mellow with a slight hint of the turbo whistle at 1200 RPM.

My engine bay is noisy, but not raspy, it's also a consistent mellow sound.
 

·
Registered
Joined
·
178 Posts
Discussion Starter #3
I had to add a wire to the ecm to get the high idle functional, I had an LB7 and had to do the same thing with it. It will bump up to 1200 RPM, and it doesn't seem to have the surge sound at that RPM, so it could just be that it doesn't like 850.

I have 4" straight pipe exhaust, with the high idle set higher you can hear lots of turbo.
 
1 - 3 of 3 Posts
Top