Chevy and GMC Duramax Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Just got my first "service 4-wd" message on my DIC today. The message appeared after I re-started engine following being shut down for 5 minutes or so. I have reset but still comes back on immediately after re-starting. I drove down the road a couple of miles, pulled over and pressed the button to engage 4-WD High. Appeard to go in OK. Tried 4-WD Lo and I was unable for some time to get it to go back to 2-WD high. Thought I was going to have to ride in for several miles under 45 mph or call a tow.

I have read several posts suggesting this may a faulty 4-WD electronic switch. Truck only has 2,500 miles, 2005 model D-Max. Any suggestions before I head to the Dealership. The GM Dealership in my town is not noted for having the best diagnostics. Had to get the fix for my 1995, 6.5 PMD problem from a diesel troubleshooting website, so you can see why I have little faith in their ability. Any Tech help would be greatly appreciated.

Thanks.
 

·
Registered
Joined
·
55 Posts
No dealership I know of did a good/great job of diag-ing ANY 6.5L problems most people resort to the internet of independent mechanics for good diags and aftermarket fixes that should be OEM...the the PMD cooler.
 

·
Registered
Joined
·
2 Posts
I had that same problem with my 2001 Tahoe. It would come on going down the road though or sometimes right after starting and it would search after trying to shift to 4WD or 4-Low. My dealer told me that GM had some probelsm with the electronic relay switches and fixed it right up for me. Haven't had any problems with it since.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Thanks. Mine was coming on because of a wire that had shorted out (due to being out of the wiring harness) running near the transfer case. Took dealer two times to get it corrected.

Hooky
 

·
Registered
Joined
·
13 Posts
I have had the same problem, and also been in 2 times....now that i know about the wiring harness, i may crawl under and check that myself... I was told it was the relay switch, but supposedly it has been changed... (yeah right!)
 

·
Registered
Joined
·
362 Posts
:confused:
 

·
Registered
Joined
·
362 Posts
:confused: this place is screwed up. I post one place and it goes somewhere else.
 
1 - 7 of 7 Posts
Top