Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 3 of 3 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I have a 2005 LLY(I think there’s a profile I can fill out that I need to do so everyone can see what I have) and I was using 4L. I was reversing and shifted into neutral to shift back to 2 wheel and suddenly I got a service 4x4 message and the lights started flickering on the switch board for the 4x4 control. Then I turned it off and back on and now the lights won’t turn on at all on the switch board and I still have the message. No check engine lights, just that little message. Any ideas?
 

·
Registered
Joined
·
80 Posts
Robert,

Do a YouTube search for "GMC 4x4 fix" and several videos come up for how to troubleshoot the system and the most common failures and fixes.

A half hour spent there may help you diagnose and fix the issue yourself.
 

·
Registered
Joined
·
250 Posts
My guys drove 80 miles on the highway withthe 4wd in 4H and the same thing,, service $WD and just got a red light in the neutral button after the flashing. I got in it and shifted it between 4 and 2wD, then a couple of shifts into 4Low, and back to 2 and everything went back to normal. Once in a great while I will get NO LIGHTS on the 4wd panel at all. But 2wheel . 4WD and 4Low all work just fine.

Have you tried engaging 4H and 4L and checked the fuses. IIRC there are 2, one for the dash controller and one for the transfer case it's self (check the fuse cluster at end of the dash AND under hood)
 
  • Like
Reactions: [email protected]
1 - 3 of 3 Posts
Top