Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
2008 chevy 2500hd 6.6lmm
every time i start the truck for the past month i get service trailer brake message on dash.
I have replaced the trailer brake control module,relay,brake light switch and trailer gain switch. All oem parts
i have checked all wiring and connections. Any suggestions? Thank you
 

·
Premium Member
Joined
·
291 Posts
Is your gain switch fully seated in the dash?

My 2013 switch was slightly loose and gave me the same message. Added a bead of RTV when I reinstalled it... no more issues
 

·
Registered
Joined
·
94 Posts
Could also be a bad wheel speed sensor or from what I’ve read a bad BCM. I found out about the speed sensor when I changed a bearing hub out. My truck is the new body style and the parts store gave me one for the classic. Took a while to figure that one out. I went through the parts change out like you, before finding that out. Could have saved some money.


Sent from my iPhone using Tapatalk Pro
 
  • Like
Reactions: RobStef655

·
Registered
Joined
·
94 Posts
What puzzles me is i don't have any abs codes


I don’t think I had any either. Could possibly be a loose or cut sensor wire. Just throwing ideas out. There’s several codes that are tied into the Service Trailer Brake message.


Sent from my iPad using Tapatalk Pro
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top