Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 12 of 12 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
My speed odometer started at zero today. When I accelerated it went up but would not come down when I stopped. I got up to 40mph, then each time I accelerated it moved higher and higher til it maxxed out at 120mph.
I never got over 50mph. Now its stuck at 120mph. Could it be frozen? Could I have crimped it on some snow/ice? All other gauges are working fine. 2004 LB7.....Its been freezing for a couple of weeks in Pa. (ice storm)
Where does the cable run to? Maybe I can warm it up or something
 

·
Administrator
Joined
·
8,815 Posts
sounds like the classic cluster fail. I would say check your batteries, but if the rest of the cluster works like normal, then it is probably the cluster.
 

·
Registered
Joined
·
85 Posts
Maybe pull the fuse for it, see if it drops back or not
 

·
Registered
Joined
·
4,350 Posts
there is not a fuse specifically for the speedo, and if the rest of the gauges are fine, there is something else wrong.. the speed sending unit could be bad.. do you have any mods at all>?>
 

·
Registered
Joined
·
79 Posts
Is the cluster fail a common problem, I am looking at purchacing a used 2003 duramax with 85,000 miles on it. I did a car fax report and I contacted the dealers that had serviced it. The small town dealer was quit frank with me, saying he knew the owner personally, and that he complained that the gauges would drop out periododically, and the the heated seats would do the same, is this something that is a common occurance, and is it expensive to repair?
Thanks
 

·
Registered
Joined
·
4,350 Posts
i have heard of the gauge thing, but i have never witnessed it first hand. as far as the heated seat thing? this is the first time i have heard of that. i know on the older (95-98) trucks there were some issues, but the new ones are great.... i have never had any kind of problem!
 

·
Registered
Joined
·
79 Posts
Thanks for the quick reply, I am new here, and will probably have a few more questions along the way. Is it ok to post the asking price for the rig, and also is it ok to ask you folks to to keep an eye out for a truck for me?
Thanks.
Abe
 

·
Registered
Joined
·
3 Posts
i have had all the same problems with my spedo just in the past week when it was real cold when he explained it i was shocked it described mine to the t same 40 mph thing and then to 120 but mine went back to 0 over night. I wanted to ask this same Question... mine is a 05 lly
 

·
Registered
Joined
·
31 Posts
Discussion Starter #11
We'll be going above 40 tomorrow. Hope the temp is the fix. No mods to mine, all original.
 
1 - 12 of 12 Posts
Top