Chevy and GMC Duramax Diesel Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter #1
My truck is approaching 167,000 miles. Over the last week, it has developed a deep squeal in the front end only while turning long left hand turns. I call it a DEEP squeal because it isn't like a brake pad sensor. It is a deeper stronger sound than that. It almost sounds as though it maybe starting to drag in it power division between left and right wheel speeds but only does it in left turns not right. This is great when added to the regular rattles and pops in the POS IFS on this thing! Maybe I will get lucky and some idiot with good insurance will run a red light soon and fix my problem for me. Has anyone else heard of or had this same problem? Thanks in advance!
 

·
Administrator
Joined
·
8,818 Posts
have you checked your wheel hubs?
 

·
Registered
Joined
·
81 Posts
Discussion Starter #3
I am on Thursday. It just seems a bit strange that it would only do it on lefts. It also seems like it has to "load up" before it starts. As if the wheel has to rotate a full turn or so first. I am assuming that you are referring to the wheel bearings but now I think that you may be talking more about the automatic locking components in the front diff. Sorry for the confusion there.
 

·
Administrator
Joined
·
8,818 Posts
No the wheel hub/bearing. Jack the front up off the ground and try 2 rock the tire at 12 & 6 o'clock. If there is movement, the hub/bearing is bad.
 

·
Registered
Joined
·
12,050 Posts
weird. mine is doing the same thing. mine is a high pitched noise. if i jerk wheel to left itll do it. if i go around turns itll do it. but turn wheel to right.nothing. its puzzling me
 

·
Registered
Joined
·
81 Posts
Discussion Starter #6
Exactly kman2468! I will be checking everything up there out on Thursday. I will let you know what I find. I suspect it will be a wheel bearing but still don't understand why only turning left. ob_1jr, thanks for your input. Hopefully you are right. That is at least an easy fix. I am checking the ball joints for other reasons at the same time. I am really tired of these front end issues. Everyone says that the Dodge has a weak front end but I never had the first second of trouble out of mine. This sucks!
 

·
Registered
Joined
·
2,538 Posts
I'd put my money on a wheel bearing. My left did the same thing when it went out. They're known for it lol. Brilliant, isn't it? :rolleyes:
 

·
Registered
Joined
·
81 Posts
Discussion Starter #8
Oh yeah nveplzd, it is just great! (Is there a sarcasm smiley?)
 

·
Administrator
Joined
·
8,818 Posts
:rolleyes: sarcastic??
 

·
Registered
Joined
·
81 Posts
Discussion Starter #10
:rolleyes: sarcastic??
Kinda looks that way. I thought it was more of a day dreaming face though. There should be a sarcasm font I think. It would make comments like my "it's just great!" seem way more powerful.
 

·
Registered
Joined
·
89 Posts
Any more info on this? I am running into the same problem and replaced one hub and sound still happens. I am ordering another hub for the other side today.
 

·
Registered
Joined
·
81 Posts
Discussion Starter #12
No sorry. My kids got sick and I am right behind them so I haven't gotten to work on it yet. I will be back on here to report as soon as I figure it out. If you do first, please do the same.
 

·
Registered
Joined
·
155 Posts
it is a hub assembly if you r turning left it might be the right front hub assembly. it will make that noise because you r putting all or most of the pressure on the right front. have some one stand out side the truck and listen for what side it is
 

·
Registered
Joined
·
81 Posts
Discussion Starter #14
I hope you are right sillachris. At least that is an easy fix. I have heard them go out in a couple of Buicks that I have owned and it sounded a lot different than this. In them, it was more of a growling sound. This is really a cross between that and a break sensor squeal. Strange sound.
 

·
Registered
Joined
·
81 Posts
Discussion Starter #15
Replaced the right wheel bearing/hub assembly today and it solved that problem. I have to do the CV's next and maybe it will hold together for the remaining 14 months that I have to keep this POS! Thanks for all of the info.
 
1 - 15 of 15 Posts
Top