Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 20 of 29 Posts

·
Registered
Joined
·
111 Posts
Discussion Starter · #1 · (Edited)
O.K. So I was installing my stereo, left the truck over night. Got in the next day fired it up and it dies right away (no smoke, no rough stop, just like I turned the key off) The Accessory position on the key does not work, windows don't work, locks don't work, interior light does not come on when door opens, key fob doesn't work. Battery light stays on and so does air bag light. I've looked over the fuses, all good. Batteries are good(truck turns over well) I have the Juice with Attitude programmer, BD X-take intake and 4" turbo back exhaust. It's a 2005 LLY. I looked under the fuse box in the engine bay, wires all good there. My guess would be ignition switch??? What do you guys say?? The switch is only $65 so I've ordered it. Thnx for the help in advance!!
 

·
Registered
Joined
·
111 Posts
Discussion Starter · #2 ·
bump bump bump
 

·
Word Up
Joined
·
3,517 Posts
sounds similar to the day i melted the coating off my POS battery cable on my downpipe and was shorting my whole truck out... Sounds like you have something shorting out in your wiring.... Mine would start and once i would start moving the cable would ground out and kill the truck intsantly
 

·
Love My L5P
Joined
·
511 Posts
It sounds like you have tripped some kind of security over ride! If I remember these stereo systems are tied into the security system.
 

·
Registered
Joined
·
111 Posts
Discussion Starter · #6 ·
o.k. so I`ve replaced the ignition switch. no go. dealer checked with Teck II and it gets a no communication error. tried the security reset crank 10 min wait 15 sec off x 3 no go. ABS light is on now too check engine light comes on too. Does anyone know what controls the gauges door locks windows and acc power it`s not a fuse or relay. the truck will start if I remove the PCMB fuse and reinsert with the key on. Anybody got any ideas I`m stumped I`ve looked over the wireing looks good and the grounds look ok found one connector on the passenger side that has 2 wires (red with black and a blue) that is severed but I can`t find what it was connected too it`s close to the fuel filter maybe some one can have a look and see where it`s supposed to go thnx guys!
 

·
Registered
Joined
·
111 Posts
Discussion Starter · #9 ·
I've unplugged the stereo and amps to eliminate that. There is no remote start. The keyfob does not work. I'm thinking there's a relay or switch or something gone that supplies all the things that are not working. Possibly a short in that circuit. I wonder if the DDM (drivers door module) could be causing problems?? I have a bunch of wiring schematics but it wouold be nice to have the starting logic so I know the sequence that is supposed to occur for a successful start does anyone have that??
 

·
Registered
Joined
·
1,248 Posts
First off Take the edge completely off the truck and put it back stock. Then if that dosent work check the harness for the radio. There is a data line (I cant remember which one it is)that cannot be grounded. Check and see if any of these help.
 

·
Registered
Joined
·
111 Posts
Discussion Starter · #13 ·
tried removing the edge no different I was thinking maybe BCM now too I'll check the wiring harness I had the truck running with the stereo and amp in ..... was installing another amp when this happened I don't want to pay the dealer to play the guessing game so..... I'm playing it now lol!!
 

·
Registered
Joined
·
111 Posts
Discussion Starter · #14 ·
anybody know how to test a BCM to prove it's no good?? other than putting it in another truck??
 

·
Registered
Joined
·
111 Posts
Discussion Starter · #15 ·
Hey LBZ The data line your talking about I think it's the door chime, that would be fed from the BCM correct?? Now if I was to take the speaker output from an amp at 175 watts and back feed through that data line what do you think would happen??? fried BCM perhaps?? it would explain all the things that are not working. I'm never drinking rye and working on my truck again!! lol
 

·
Registered
Joined
·
1,248 Posts
Sounds like it could fry the bcm. Check all fuses....not just look at them put a meter or a new one in. I have had fuses here lately that looked good but were not. But for now disconnect the data line and make sure it isnt grounded and then try it.
 

·
Registered
Joined
·
553 Posts
you need to see if you have gmlan communations it is high speed and if you do have have gmlan and you installed a aftermarket radio everyting on the other side of the radio on that communation line will not work did you put your old radio back in and see what happens , if it is that you will have to jumper the communation lines around your radio
 

·
Registered
Joined
·
111 Posts
Discussion Starter · #18 ·
the truck ran after i put the stereo in happyduramax it was when I was putting in another amp that this problem happened
 

·
Registered
Joined
·
553 Posts
if you remove the amp you just install will it run right i was just looking at the wire diagram for your truck and it should have no effect on the truck ,shouldn;t the key word , check all of your fuses with a test light , what modules does the scanner talks to
any codes in any of the modules ?
 

·
Registered
Joined
·
111 Posts
Discussion Starter · #20 ·
the Tech II won't communicate with the computer, but the ECM runs through the BCM and if the BCM is fried then..... I've checked the fuses with a test light and an ohm meter I've checked the wiring harness from the data port to the wiring harness looks good. the only other thing I can think of is if there's a break between the ECM and the BCM, but the truck ran till I parked it and the only other thing I've done is install the amp. If I unplug the PCMB fuse with the key on and reinsert it the truck will start and run fine with the exception of the gauges, locks, interior lights, and key on acc. power. Hey happyduramax what does your truck do if you unplug your BCM??
 
1 - 20 of 29 Posts
Top