Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 6 of 6 Posts

·
Registered
Joined
·
487 Posts
Discussion Starter · #1 ·
I noticed that recently my speedo has been kindof not moving smoothly but more in a jerking manner. My other gauges all still move smooth. Is this a sign of the stepper motor going bad? I know GM had a recall on my year for this but I am way over the warranty. Any help? Should I just replace them all?
 

·
Registered
Joined
·
686 Posts
My amp gauge did weird stuff and was all over the place and jerked when it moved. Conclusion was the stepper motor. I was out of warranty on mine too so I replaced them all with an "upgraded" version. Works great. At DP, roswell did a tutorial with pics that you can download. If you can't find it, let me know. Good luck.
 

·
Registered
Joined
·
487 Posts
Discussion Starter · #3 ·
Thanks Audio, I was thinking it was the stepper. It shouldnt be too hard to fix as I have soldering experience. Now just to decide if I want to fix the couple burnt bulbs while Im at it.
 

·
Registered
Joined
·
686 Posts
There is an LED mod for the bulbs too. Might as well check it out and fix it all while you are in there.
 

·
Registered
Joined
·
487 Posts
Discussion Starter · #5 ·
I agree, but I heard you cant dim with LEDs. Will have to look into it.
 

·
Registered
Joined
·
686 Posts
At DP there was a thread in the DIY section called "LED Dash cluster..." started by JHforman. He indicates that the bulbs still dim (post # 15). This was an excellent thread on the subject.
 
1 - 6 of 6 Posts
Top