Chevy and GMC Duramax Diesel Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I was hoping for some info if anything I am out of town and have been on the road for 1200 miles so far and at about 700 mi my ses light came on and i lost power luckily I was right near a parking area I pulled over turned engine on and off a few times with no change so since I had a bully dog chip installed I figured I would disconect and just run the stock stuff I restarted the truck ses still on a nd proceded to drive with no problem I stopped at the next rest stop went inside for 5min or so returned to the truck started lamp wnet out when I reached my destination I took the truck to a local dealership and they checked it out and said there were so many codes they didnt know where to start cleared all the codes sent me on my way I drove the truck loacally for about 150 200 miles no problem but ofcourse as soon as I set off to go back home the same thing happened but now its not correcting itself I can drive about 10 miles at full speed and then it shuts down like it is in limp mode I pull over and restart it a few times and I can go again sometimes I can go 20 or 30 miles before it happens well right now I am in a hotel near sturgis mich a dealership is down the road i will go in the morning but figured you guys would probaly know more than them HELP also I have been towing a traile which now I have a car on and my truck is a 2001 2500hd 6.6 turbo any help would be great:confused:
 

·
Hi, I'm Earth. Have we met?
Joined
·
3,163 Posts
With them saying there were lots of codes i cant really offer an oppinion unless you know the codes? MY first guess would be again a dirty fuel filter, and the extra load of the trailer now it is just magnifying the problem. but again with out knowing if its a code p1093 or not i dont know?

Caleb
 

·
Registered
Joined
·
484 Posts
I'm gonna have to go with Caleb on the clogged fuel filter, let us know how you make out.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
thanks

I will let you know I just checked for chaffed wiring ect and disconected the trailer the light went out and drove fine I will have them scan for codes reprogram the computer replace the fuel filter and hope for the best
Thanks again
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
still 800 mi from home

So I took the truck to the dealer and they told me two or three injectors are bad and they would replace all of them under waranty hopefuly finsh the job by tues (tommorow) eve? Do you think this will solve the problem and what are the chances of them finishing the job in one day?
 

·
Hi, I'm Earth. Have we met?
Joined
·
3,163 Posts
THey should have no prob finishing the job on time. THe sympyoms dont really fit bad injectors though?

Keep us posted
Caleb
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
symptoms

I have to agree with you the tech said i only had 105 psi fuel pressure which was not enough to run down hwy towing trailer i will make sure they also replace fuel filter any other suggestions
thanks for you help and support
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
Home safe

Well I have to say the dealership suprised me they had the truck done by 100pm tue I left drove 800 miles straight home truck ran like a charm they changed the injectors the fuel filter and the oil I noticed the truck runs MUCH smoother and seems quieter but the mechanic ernie at kool chevrolet in sturgis mich did an awesome job quality and speed what a great mechanic
thanks for all your help and support its nice to have my diesel back and running smooth again!!!!!
 
1 - 8 of 8 Posts
Top