Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 7 of 7 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
OK, after reading for hours on here through the search tab most of the problems are at idle.. my truck runs and idles fine till you get to 45 then it starts surging, if you press on the throttle it starts to shake till you get to 60 then goes away. The dealer said it was the fuel filter so they change it. well today it was worse then ever I turned around and took it back to them as soon as they opened. I just bought this truck last week and they told me they would take care of the problem. I know they didn't make much money off of it and they aren't going to want to spend much money on it. If I can get a idea of what it is I'm sure i can do the labor part. It almost seems like it's going to slow to be in overdirve...like it's wanting to chuge along. kinda like being in 3rd gear when you needed to down shift and didn't. any help would be great.
 

·
Premium Member
Joined
·
1,972 Posts
I would keep on them until it's fixed to your satisfaction....otherwise give them back the truck and get another truck...
 

·
Registered
Joined
·
763 Posts
STAY ON THEIR ASS. Don't let a crappy dealer taint your first experience with a duramax. The motor and tranny are great.
 

·
Premium Member
Joined
·
163 Posts
Mine will do the same thing but at 50mph. It only does it when slowing down from high speeds and its still in 6th or 5th gear. If I get off the gas and let it slow down and than get back on the gas its fine. I think it just stays in 6th a bit to long and lags.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #5 · (Edited)
They told me today they were going to do a flash on my ecm and it could also be my egr valve because it was manual..so it wouldn't through a code. basically they don't know what it is...
 

·
Confidence Antler
Joined
·
1,997 Posts
With those speeds it sounds like it could be the torque converter acting up.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #7 ·
They told me today they found a rubed spot in my #2 injector wire. Could that cause this ? I hope so. I'm ready to get my truck back after a week now.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top