Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Vote for the Site Favourite ROTM winner for the year of 2021 HERE!
1 - 10 of 10 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter · #1 ·
Ok I get fuel at a shity place (i know bad idea) so i just get enough to get to the closest fuel station thats good (about 20 bucks) by the time i get there my truck seems to be idleing high at about 900 rpm then i notice the tranny acting funny. i come to a stop when i go the engine rev's then i let off the throttle and 1st engages. so i think bad fuel i imediatly go fill up with good fuel to try and dilute the bad. well now i am through a second full tank a new oil change trany spin on and doing the fuel filter tommarrow. what i noticed is it seems to only do it once or twice with in the first 15 min of driving then its gone until i shut the truck off. the truck has 191.000 on it maybe internal filter is cloged. i just dont see how the fuel filter would cause it to not engage 1st when cold. thanks
 

·
Registered
Joined
·
1,486 Posts
Not sure what to make of that but sounds like a hesitation.... Yes fuel filter is were you should proibably start. Is ther any other things going on?
 

·
Registered
Joined
·
108 Posts
The internal tranny filter should not need to be changed for the service life of the tranny, under normal operation, and provided you change the spin on filter every year, change the fluid as specified, and you don't burn up any clutch packs, or harm the internals of the tranny. Is your tranny fluid low? You might check the NSBU switch on the tranny to make sure it has not shifted or come loose, as that could cause the tranny to not fully go into the gear that is selected. Not saying that's it, just something to check.
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #4 ·
list of everything done

new spin on new internal (found dipstick tube had a hole in it) new dipstick tube total trany flush pushed 8 gal through new fuel filter new oil new transfercase fluid new nsbu. its really wierd is there a servo or somthing that pushes it in to first as you come to a stop? after the fluid change it seemed better for a day then started up again. it is only first gear and it only happens as i come to a stop it either clunks into first like engages the torque converter lock up or i come to a stop and then hit the gas and she reves then the rpms drop and goes into gear with a thud. i really dont want to f*** up my tranny seeing as this is my only work vehicle. i have figured out the best way to drive it now. as i come to a red light i slow down give the motor a little fuel goes into gear then i stop. what a pain in the balls. someone who knows about the allison 5 speed HELP!!!!!!
 

·
Registered
Joined
·
174 Posts
To me it sounds like your c5 piston is leaking causing a hesitation when you go into first. The pressure takes awhile to build up do to the leak causing c5 to apply slow. Also could be a sticky valve but thats usauly not so predictable as your problem.
 

·
VAGITARIAN :)
Joined
·
7,336 Posts
Verify correct fluid level,spin on filter should be fresh,you may want to drain pan,then replace 7 qts. of oil,and be sure that the NSBU switch is working properly,when they going out usually it'll show weird shit on the shift selector/gear indicator on dash..
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #7 ·
Ok the list of things done to the truck have all been done this week withthe exception of the injectors(6months) nsbu(2 months). Ok the c5 is that hard to change and is it expensive?
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #9 ·
There is no problem with the fuel system. I believe the diesel I bought was thined with gas which increased the idle which at first I thought was the prob. Ie.high idle causing first gear to engage early or late now my idle is fine. The prob is in the tranny. When cold or after the highway the first stop I make usually first engages late I believe c5 or the clogged whatever sounds right on. The thing is who knows how long the hole was in the dipstick tube for. The internal filter had plenty of junk in it.
 

·
DuramaxForum Veteran
Joined
·
4,506 Posts
Overfilled or underfilled fluid will cause this but if that is all okay then i would start looking into other things.

If you were having issues with a cracked C5 apply pistons (rare) then you would also be having issues with reverse.

Are there any codes??
 
1 - 10 of 10 Posts
Top