Chevy and GMC Duramax Diesel Forum banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
38 Posts
Discussion Starter #1 (Edited)
The truck in question is...2007 GMC 3500 4x4 LBZ 6speed allison..

Sometimes the trans won't inguage and you have to turn it off and on a time or two. It acts like it's the nutral possition switch but the dealership said it doesn't have one!:what

I read in another thread that maybe changing the filters and fluid might help but the fluid in this truck is very clean already!

Any ideas on what else it may be??

Thanks.
 

·
I'm That Guy...
Joined
·
16,689 Posts
When did you change your fluid and filter last?
 

·
Premium Member
Joined
·
38 Posts
Discussion Starter #3
It's a recent purchase so not forsure but the fluid in this truck is very clean and bright red! But I guess they could have only changed the fluid and not all the filters so I will service it and see if it happens again..

If the service doesn't fix it does that mean the pump is bad or whole tranny or???
 

·
Premium Member
Joined
·
17,806 Posts
Might be the pressure switch--pull the pan-- it is the tin looking part that is attached to the valve body.

If someone has a Tech II, and knows how to use it,-- they can check the operation.
If you want to guess -replace that. It is not very expensive.
 

·
Premium Member
Joined
·
38 Posts
Discussion Starter #5
Dropped the pan and the filter was laying in the pan! I'm thinking that was the problem.?
 

·
Premium Member
Joined
·
17,806 Posts
Ding Ding-- I think we have a winner. That sounds like the problem-- sucking air. They do make a filter lock for the deep pan and the standard pan. Abt $20.
 
1 - 7 of 7 Posts
Top