Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 20 of 25 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Just bought a 03 gmc 3500 dually with 50k on it. Had iT for about 5 weeks no issues. I went to put it in drive yesterday and the indicators didn't light up for drive, neutral, and second gear. Then, BANG!! It shifted into drive. Then I did it again to make sure. BANG! Now I'm getting hott. So once I leave the mall, I step on it. There's a lil hesitation in second gear. Its not too bad. But today when I went to go to work, I got a BANG when I put it into drive, then I was going down the road and it was reving really high without shifting. I put it in 3rd and back into drive and then it shifted and the indicator went back on. Then shut off shortly after. Any ideas? Dealers taking it in on monday but I don't want some bullshit story from them. Thanks appreciate it.
 

·
Registered
Joined
·
809 Posts
there is a switch on the side of the transmission that goes bad,i dont know if this is your prob,maybe someone else chime in,just putting my 2 cents in!
 

·
Its just a worktruck
Joined
·
13,908 Posts
NSBU switch. You can change it yourself. Its on the outside of the case.
 

·
Premium Member
Joined
·
17,806 Posts
NSBU-- Neutral Safety Back Up switch- Don't buy from the dealer-($230)- Allison dealer is about $70-- Napa about $40. :D
 

·
Registered
Joined
·
2,379 Posts
NSBU. they are known for it
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #6 ·
cool guys, thanks guys. dealership said "we dont work on the allison transmission, we would have to send it out to allison" (thats garbage). so that should solve that banging issue. so i may have to take care of it myself. also, wondering about the lil hesitation during full throttle. its hard to explain, it will take off pretty good, but then feels like it shifts around 2000rpms but i know its not shifting. is that what they call a "slip"? ive never had a tranny slip before. thanks.
 

·
Its just a worktruck
Joined
·
13,908 Posts
I think you may be feeling the Torque Converter lock up. It happens in 5th gear around 50 mph or at WOT above 2nd gear. If the clutches slip you will get a code 99% of the time.
 

·
Hi, I'm Earth. Have we met?
Joined
·
3,162 Posts
All your issues are from a bad NSBU switch, In short, the tcm dose not know what gear its suposed to be in, so it defaults to 3rd with no TC lock up! Thas banging is because its going straight into 3rd gear insted of 1st!
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #9 ·
yeah no codes. but ill change that switch and go from there. thank you all.:drink
 

·
Registered
Joined
·
267 Posts
sorry to hi jack but could the be why my reverse lights don't work?
 

·
Premium Member
Joined
·
17,806 Posts
The NSBU switch will also affect the back-up lights-- Yep!
 

·
Registered
Joined
·
360 Posts
Just so you know, the plugs on the switch have to be heated to get the glue inside to melt or you cant get it apart. I have a 29 dollar heat gun that I used, I don't know if a hair dryer will work, maybe someone else can chime in if it works. Also to go back together.
 

·
Registered
Joined
·
108 Posts
New here and have a similar question. Shifts fine driving but when i get on it it hesitates to shift once i get aroung the 50 mph point?
 

·
Registered
Joined
·
2,379 Posts
alot of the operation of your truck comes fom the NSBU when you start it and to make her dive down the road
 

·
Registered
Joined
·
2,379 Posts
New here and have a similar question. Shifts fine driving but when i get on it it hesitates to shift once i get aroung the 50 mph point?
you are feeling what they call defuel which is a factory setting
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #16 ·
my reverse lights work. reverse actually shows up on my indicator, its park, neutral, and drive that dosent lol. i first noticed it when i put it in park the doors didnt unlock like they normally do. i remeber my old surburban, the reverse lights didnt work and i believe it was that switch... hmmm...:confused:
 

·
VAGITARIAN :)
Joined
·
7,336 Posts
once you change the switch it will act normally
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #18 ·
changed the switch, everythings back to normal. thanks a bunch. also another question, backing up really slow with brakes on, i feel something pulsating. with trailer and without. it makes me think im hitting something like a soft snowbank, but im not. what could that be??? the torque inverter? it cant be the brake rotors because it pulsates multipletimes before the wheels even make one half rotation. any ideas?
 

·
VAGITARIAN :)
Joined
·
7,336 Posts
hydroboost...................that's how it acts,this is particularly true of turbo vehicles!
 

·
Registered
Joined
·
256 Posts
Da*n, a fourty dollar part causes all kinds of misery.
 
1 - 20 of 25 Posts
Top