Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 10 of 10 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #1 · (Edited)
Hi Guys,
I own a 02 GMC 2500 HD D/A CC/SB with about 83000 miles on it. I have had regular maintenance such as filter and fluid changes. I did reprogram the truck with the Hypertech unit for level 3 Power and recalibrated the speedo for the 258/75/16 tires.Here is the problem;when I am accelerating up a grade with the cruise on or off the truck starts to shudder sort of like a standard when you start off in the wrong gear. It also does it when I am merging from an on ramp into traffic. Sometimes it is slight and sometimes it is very noticeable. I actually stopped by my GM truck dealer yesterday and took one of the techs out for a ride and he noticed it as well. I am supposed to drop it off tomorrow to them so they can see what is causing the problem. Any suggestions or clues I am all ears. Oh yeah when I accelerate real hard :gearjamin is sometimes acts as if it is skipping. Let me know. Oh Yeah BYW The bed bladder that I put in the back of the truck has definitley taken out what GM calls Frame beaming. The truck rides pretty smooth. With the bladder full it adds between 400-500 lbs to the back of the truck
Pilot:cool:
 

·
Oh...... Squirrel!
Joined
·
24,083 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #3 ·
Uh Oh:eek: . No I haven't done anything to the Tranny. I did deprogram the truck this morning before I bring it in tomorrow so they can check it out. I know they say you can reprogram the shift points with that unit, but I never did it. I am going to take the truck out later and run it and see if it is still shuddering with it deprogramed. Thanks for the reply.
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #4 · (Edited)
Hi Guys,
Good news. The dealer had to do a couple of upgrades to the Tranny and now this thing really hauls :gearjamin . I picked it up tonight and reprogramed it back on leve 3 and it is a lot smoother and it is a lot qiucker. Very happy:rockin :rockin :rockin
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #5 ·
Well that lugging shudder is back again when going up hills unless I put a little extra on the loud peddle:gearjamin . Like I said I have the hypertch programmer but how do you or can you reprogram the shift points with the programmer??? Any info would be appreicated and helpful. Btw the techs told me that tranny was ok.
 

·
Oh...... Squirrel!
Joined
·
24,083 Posts

·
Registered
Joined
·
142 Posts
If it was the trans slipping, you would get a light on the dash. So here comes the standard questions, have you changed your fuel filter lately? Is it possible the injectors are going bad? I doubt it has anything to do with the programmer...but one can never tell.
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #9 ·
The fuel filter and the housing have been changed recently within the last 3 months. The injectors were checked and I was told they were working properly. I am going to try to manually downshift the next time it happens and see if that is the problem. Like I said it acts as if you are driving a standard shift vehicle and you are lugging the engine going up a steep hill.
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #10 ·
Hi All,
Well the dealer finally found out why my truck was shuddering. I went in for an LOF last Friday and they told me I had Diesel Fuel in my oil. They told me that it WAS THE INJECTORS. They told me not to worry that they would cover it under warranty and get me a free loaner with unlimited mileage. The name of the dealer is GENDRONS TRUCK CENTER IN TROY, NY. These guys have been awesome since I started going to them since the middle of last summer for all my service work. Here is the best part. The truck is an 2002 and I bought it back in 2003 from a friend of mine who owns his own car lot. They told me that the injectors are supposed to be operating at 160 and they were operating at 120. I picked it up last night and it appears to be running great.
 
1 - 10 of 10 Posts
Top