Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 3 of 3 Posts

·
Registered
Joined
·
90 Posts
Discussion Starter · #1 ·
Question. Sometimes My brake and abs light come on (and stays on when it does) at start up. Sometimes it doesn’t. I have a c0550 code but I’ve noticed when I pulled the fuse out of my fuse box for my lift pump so it doesn’t just sit there and run while I’m messing with the scanner the abs light goes off. If I turn the key off/on and u see them come on the cluster like it’s doing it’s routine check for the abs system the abs light doesn’t come on there either....just the brake light comes on. The lift pump fuse is in the ignition e slot right by the relay for the starter. Wondering if anyone has had the same problem or can explain to me why the abs light doesn’t come on when I remove the fuse to the lift pump.

I already cleaned the ground under the driver door to try to fix the code. not sure if there is any other connections I need to clean to try to fix this before I throw parts at it.
 

·
Registered
Joined
·
4,144 Posts
It always helps those of us who have never seen your truck to know year end equipment (4wd, stock, deleted, ambulance, antilock brakes, etc) Keeps us from guess the myriad of possibilities of what might be wrong. Is your lift pump part of the stock setup? Or aftermarket? Are you aware the C0550 is for internal ABS error? And that error will turn on the brake and ABS lights on you IP? Have you looked at a wiring diagram for your truck to see what circuits are protected by that fuse that you remove?
 
1 - 3 of 3 Posts
Top