Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Vote for the Site Favourite ROTM winner for the year of 2021 HERE!
1 - 7 of 7 Posts

·
Registered
2006 CCSB Chevy 2500hd
Joined
·
103 Posts
Discussion Starter · #1 ·
I just pulled codes on my edge programmer and it pulled code u0100 lost comm to ecm/pcm a. Check engine light isnt on and everything seems to work fine. Set programmer back to stock same code still no cel or problems turned back up to performance no cel and again no problems. Anyone know why it would be pulling this code?


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
11 Posts
That's just the reader losing communication with the ECM. Nothing to do with your truck itself from my understanding. Don't quote me on that but I'm about 99% sure that's what that code means.
 

·
Registered
2008 Silverado 2500HD
Joined
·
908 Posts
Could be wrong but I think that code comes up everytime you change your tuning file. Does not illuminate CEL I wouldnt worry about it as long as the truck is running like it should. clear it and see if it comes back
 

·
Registered
2006 CCSB Chevy 2500hd
Joined
·
103 Posts
Discussion Starter · #4 ·
Could be wrong but I think that code comes up everytime you change your tuning file. Does not illuminate CEL I wouldnt worry about it as long as the truck is running like it should. clear it and see if it comes back
Ive cleared it several times and it just keeps coming back. Im not to worried about it. Just wanna know what causes it. Lol


Sent from AutoGuide.com Free App
 

·
Registered
2006 CCSB Chevy 2500hd
Joined
·
103 Posts
Discussion Starter · #5 ·
That's just the reader losing communication with the ECM. Nothing to do with your truck itself from my understanding. Don't quote me on that but I'm about 99% sure that's what that code means.
Idk. Ive heard of some people throwing that code but there cel also comes on and it causes there truck to run like crap or shift like its in tow haul mode.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
672 Posts
I got that when my batteries were totally drained.
 

·
Registered
Joined
·
11 Posts
Idk. Ive heard of some people throwing that code but there cel also comes on and it causes there truck to run like crap or shift like its in tow haul mode.

Ah gotcha, one time when I went to clear my MAF code at Autozone they said that popped up and that's what they told me. I never trust anything that comes out of the mouth of an auto parts store employee though unless they prove to me that they know what they're talking about. Now I'm curious.
 
1 - 7 of 7 Posts
Top