Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Vote for the Site Favourite ROTM winner for the year of 2021 HERE!
1 - 20 of 32 Posts

·
Registered
Joined
·
591 Posts
Discussion Starter · #1 ·
Had a few parts from WCF put in my truck, and I have a really bad vibration just off idle. Sweet spot is about 850, gone at 1,000.

List of mods:
WCF twins, 475 over stock
WCF CP4 delete
Sportsman CP3
Tranny upgrade

List of things checked by shop:
- Exhaust -completely disconnected, still rattles bad. Nothing touching
- TC checked, not coming from there.
- Motor Mounts are good
- LB7 up pipe tight

Vibe is coming from motor, or something bolted to it. Had no vibe pre kit.

I'll host a video after work to show you how bad it is. Any ideas?






Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
7,848 Posts
Who put it in? Is your drivers side intercooler pipe touching the hydra boost? Mine does from time to time and rattle like a crazy man
 

·
Registered
Joined
·
591 Posts
Discussion Starter · #3 · (Edited)

·
Registered
Joined
·
7,848 Posts
Downpipe rubbing? Holy cow man they better fix it
 

·
Registered
Joined
·
591 Posts
Discussion Starter · #5 ·
Downpipe is clear. They pulled the exhaust right off. Said you can see the top of motor shaking. They bumped the idle rpm to make it sit in sweet spot of vibe. Says he can feel more vibe in the 475 side.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
7,848 Posts
Ahh I'm having a hard e coming up with what it could be...who does your tuning?
 

·
Registered
Joined
·
591 Posts
Discussion Starter · #7 ·
They are, they have a guy doing the EFI in house. They had to pull a bit out of tune. It was really hot from a dead stop. I could peg 1800 from a dead pull. But if I eased to 20psi, then stabbed it, 58psi, and 1300f

Now 1400 at 55psi. It's gonna take some playing with. I think the stocker is working too hard, and causing the high egts. I think we gotta tune in more lag, and allow more boost from 475, before cranking veins on garret. Lots to consider I guess, getting twins to balance with my high Curb weight, and CP3. I'm guessing I'm around 600, was hoping for a bit more. 650-7




Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
1,779 Posts
Does it drive fine other than the noise? Just for kicks does the harmonic balancer shake when it's making that noise?
 

·
Premium Member
Joined
·
1,092 Posts
Hate to hear it man, my question is did it start vibrating on the first start up or did it start vibrating after a couple test runs? I guess the shop woulda started it up first so probably can't answer that..
 

·
Registered
Joined
·
7,848 Posts
I'm wondering if it's the tuning, or like Robby said, does the balancer shake...maybe an internal issue
 

·
Registered
Joined
·
591 Posts
Discussion Starter · #11 · (Edited)
Started right with kit. They thought it was exhaust. Messed with exhaust as my flo-pro fits terrible. They are trying a new balancer tomorrow. But wasn't an issue before. It drives fine other than it ran hot. Which I found very weird, zero smoke, and I mean zero. It smoked more with optimized stock and deletes. Yet could peg 1800 from a stab. Thinking its a turbo balance issue, since easy 20psi then WOT made 13-1350. Which tells me it's top half fuel air is good, and no smoke tells me it's not excessive fuel on bottom. Thinking its more trying to make too much boost when the 475 isn't pushing, and over spinning the VVT. Isn't the load sharing supposed to be 1/3 - 2/3 for twins?


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
1,743 Posts
Really weird, wasn't doing it before and then "all-of-the-sudden" a vibration popped-up after installation.

I would focus on the kit, possibly an issue with the turbo, like mentioned above.

Sub'd for results when find source of vibration because will be installing WC Fab twins on my truck in the next 6-7 months.
 

·
Registered
Joined
·
591 Posts
Discussion Starter · #13 ·
I'm confused how it could be the turbo. Either turbo vibrating should have ate themselves once I hammered the throttle. That kind of RPM off balance, or with any form of play should have caused drastic failure.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
1,687 Posts
Check all the heat shields? I have some kind of resonance around the same rpm with my kit but it doesn't vibrate like that.
 

·
Registered
Joined
·
1,779 Posts
Pull the air filter from the big charger & look at the wheel. Did the front cover come loose from the clamp?
 

·
Registered
Joined
·
1,779 Posts
Find anything out today?
 

·
Registered
Joined
·
591 Posts
Discussion Starter · #17 ·
Shop says cold pipe off turbo is touching y bridge. Nothing they can do right now. Gotta get another pipe. They don't want to try and bend it.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
541 Posts
First off would definitely have someone else handle the tune if your running the twins and its pegging 1800 from first time around. that's a ridiculous figure if they're anywhere near normal parameters in the pulsewidth with stock sized injectors....stock turbo max effort pegging out end of a quarter mile pass barely hit 1800. You can usually run decently with a regular tune with twins and it run a bit funky in boosting but not 600* hotter EGT's then normal. Unless your helping the in-house guy out with practicing his tuning, that would sure scare me real quick with my motors longevity.
I know a good enough amount tuning with EFI live that that's some red flagness, even though tuning tables on an LML are a different ball game then previous ECMs.

Haven't played with wherlis twin kit, but i'll go out on a whim and say theres probably just enough play there between the pipes that maybe just the angles aren't 100% causing the touching. That and realistically instead of a new pipe, worst case take the pipe out and ding in a flat spot. Obv its an expensive kit, but if it's just enough clearance issue to cause a rattle I'd go about hitting that spot with a rubber mallet a couple times and be good to go!
When I put the twins on my LLY theres quite a few places things are close and can touch. Don't get me wrong but that loud of a vibration I feel you could find in no time if putting ear up to everything there! Especially if installer remembered parts that were close to touching.

Looks like a sick setup when you get it dialed in. The 1800 EGT's in tuning still scares me. You shouldn't see above 1450ish trying your hardest.
 

·
Registered
Joined
·
591 Posts
Discussion Starter · #19 ·
Yeah, 1800 wasn't pretty, I was just doing pulls in it. And from cruising 10-15psi, leaning into the skinny petal, I would heat up. I would let out between 14-1600 which is pretty much 3-4s after punching it.

Once I figured out if I went soft till 20psi then pull, it stayed cool, I thought I'd see if it was a short term spike till flow came through, and if it would settle down, that's when I saw 1800, and I lifted my foot.


Sent from AutoGuide.com Free App
 

·
Its just a worktruck
Joined
·
13,908 Posts
You shouldnt see anything above 1500 with compounds. And thats on a long pull in high gear. you might have a few boost leaks and or drive leaks. Why not have Rob tune it? Hes the master of the s475/stock setup.
 
1 - 20 of 32 Posts
Top