Chevy and GMC Duramax Diesel Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
625 Posts
Discussion Starter #1
my truck seems to lose fuel or something. i will like lose the throttle and it will slow down but i'll keep my foot on it and it will pick up maybe jump then go like normal. i noticed this going to and from pigeon forge awhile back, it only happens going up a large hill, for instance every time it done it i was going up the cumberland plateau to and from pigeon forge, and then on the way back from chattanooga up monteagle mountain. 3 times..... i changed the fuel filter on the way back from P.F. and it seemed to quit but didnt go back up another big hill. the new filter has only be on for maybe 1000 miles. oh, and i do not have any codes or anything. never flashed a light.:help:confused:
 

·
Registered
Joined
·
96 Posts
look into testing your throttle positioning sensor
 

·
Registered
Joined
·
625 Posts
Discussion Starter #4
it feels like i let off the throttle completely...but i'm still on it. a tps would do it all the time though not only going up a hill. i've flattened the pedal to the floor and never had a problem.... it seems like i get a fuel blockage momentarily then it blows through and i have full flow again. make more sense that way?
 

·
Registered
Joined
·
33 Posts
same problem

I'm having the same problem with my 2001. So far it's has done it only when I'm towing (boat or travel trailer), and when pulling a hill. It feels just like the fuel supply has been cut off, all I can do is pull over and let it coast till the engine catches again.
I have been changing fuel filters at 10K miles. I just changed again after the last episode..filter looked clean, but had a couple of milky drops of fluid around the top of filter. I'm thinking it might be water in the tank.
Does anyone know if the fuel pickup is at the back of the fuel tank? Might be that water is rolling towards the rear of the tank as I go uphill?? Never did get a WIF indication at the dash.
I have had the fuel filter either gel or freeze up once. I had to heat the filter to be able to start the truck.
Looking forward to some ideas. :help
 

·
Registered
Joined
·
8 Posts
most probable cause is the fuel Injection pump. not being able to hold the 26000 psi in order to run at full throttle. the only way to verify is to use a scan tool and command pressure to 100mpa and to graph the fuel regulator to see if has a jagged line or it is smooth. this needs to be done at operating temp (180 degrees) if the fuel pump shows ok then you probably have injectors that are leaking thru the retun line. hope this helps
 

·
Registered
Joined
·
33 Posts
help

Diesel tech, thanks for the reply. Would this normally set a code? So far nothing indicated, except one glow plug out. Thanks
 

·
Registered
Joined
·
69 Posts
mine is doing the exact same thing. only up hills changed the filter nuthing different. I think my cp3 is going bad anyway it is very loud AKA fuel knocking or something. I have checked injector readings and they all are good. pump preasure seems good too but who knows.
 

·
Registered
Joined
·
625 Posts
Discussion Starter #9
it wasnt even at full throttle though....not even close. it was maybe at half throttle. and if the injectors were leaking through the return then it wouldnt just randomly do it? it would do that all the time even when i stomp it from a stop. it didnt do it when i pulled the trailer either. it wasnt extremely loaded but i did get on it a bit. i dunno it just irritates me i guess....
 

·
Registered
Joined
·
2,379 Posts
Diesel tech, thanks for the reply. Would this normally set a code? So far nothing indicated, except one glow plug out. Thanks
no it wont set a code if its not servre enough. if your commanded fuel is below 26,000PSI then your pump is weak and starting to wear out. you can check your fuel threw EFI or TECH II scan tool.
 

·
Registered
Joined
·
625 Posts
Discussion Starter #12
so i was coming back over the hill from chattanooga pulling a 16ft trailer w/ 3 rolls of hay and one in my bed and it did it as soon as i hit the hill then again right at the top. i don't understand how the cp3 could not perform on the hill but can at WOT on a typical interstate hill. and i've tried to make it do it!? is this a personal experience problem Mike?
 

·
Registered
Joined
·
2,480 Posts
Mine does it just running down the hwy at 70mph. Just like I let off and get back on it with out my foot even moving off the pedal. Mine doesnt do it offen but has a few times.

Knockin on wood tho just in case
 

·
Registered
Joined
·
8 Posts
on newer modelsthis concern would probably set a code for low fuel pressure. look to see if pump is leaking fuel. it would be minor like a wet spot. the have ceramic rollers in them and they crack and or wear because not lubricated by the fuel very well. check your fuel lines for kinks and replace as necessary. can you get a fuel vac gage and hook on and find out what the vac reading is when it does this? it should not be anymore than 8. I have found both bad pumps and injectors causing this problem. once injectors get hot and fuel is hot the return becomes high and not enough fuel to run injectors. need to be tested. not the easiest thing to do.
 

·
Registered
Joined
·
625 Posts
Discussion Starter #15
it would be hard to do the fuel vac gauge running 70 up monteagle. i cant get it to repeat itself except on that hill.
 
1 - 15 of 15 Posts
Top