Chevy and GMC Duramax Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
485 Posts
Discussion Starter #1
my dad has an 01 dmax that is all stock. his wipers will only work on high, every other setting does nothing. someone told him to change the black box that is in the steering column and he did but still nothing. his cruise and high/low switch works. he doesnt want to keep replacing parts that are bad. i think maybe the switch itself is going bad but does anyone have any other ideas?
 

·
Im Superrrrr!
Joined
·
14,517 Posts
I would say the stalk has part of it toast....Not sure if it has a relay in the fuse box or not. May want to check that.

LMC truck has the stalks for....quite a bit...
 

·
Oh...... Squirrel!
Joined
·
24,083 Posts

·
Registered
Joined
·
412 Posts
My truck just did the same thing, I was told there is a wiper motor pulse board that may have gone bad. Has anyone else heard of this?
 

·
Registered
Joined
·
165 Posts
my 03 wipers would get stuck on high when ever you turned them on, only way to stop them was pull fuse. Ended up changing wiper pulse board under cowl and fixed problem.
 

·
Registered
Joined
·
412 Posts
mine work fine with the switch, its just that they only work on high none of the other speeds work. my wife was driving when it happend and said snow slid off the top of the truck and prevented the wipers from going all the way down. ever since they only work on high speed. will have to pull the pulse boad and see if its cooked. thanks.
 
1 - 7 of 7 Posts
Top