Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I'm a newbie to this Forum but not to mechanical things of any kind. I've had my '07 Sierra 2500 HD 4X4 since '08 it has performed well all these years. Both myself and my wife love our truck and I am stumped about how it's been acting since just a few days ago so I seek help.

It starts fine when cold but after about 20-30 minutes on the road the gauges stop functioning (except for the battery gauge), the A/C stop blowing cold air, the trans shifts differently, and "Service Four Wheel Drive" comes on the message center and I cannot engage it. Everything else continues to work... lights, brakes, windows, radio, etc. If I turn it off it will not restart without at least a 20 minute cool-off period. After that it will restart but the gauges, A/C, 4 wheel drive won't function and the trans still shifts differently but at least I can drive it (if I drive it like a station wagon the trans shifts normally. But if I try to pass or speed up quickly the shift patterns are very different). If I let it cool for about 45 minutes than everything will work fine again, including the trans & 4 wheel drive, and the "Service Four Wheel Drive" message is gone. But after another 10 minutes of driving it all starts over again.

My check engine light has been throwing an EGR code some time now but it comes and goes so I haven't done anything about it. I thought it might be the ignition switch so I replaced it but it didn't help. I replace my trans and fuel filters every other oil change and it gets mostly 55-75+mph driving. Last year I installed a LivewireT5 tuner and a Banks cold air intake. My gas mileage is 11-16-20mpg (towing, daily, highway cruising)

The only thing different I've done from other years is not driving it during this summer. We live in Central Florida, close to DAytona Beach, and decided to bail out during the hot months so we spent this summer up north and we took our other vehicle. While away, we had friends check our house at least monthly and start the truck and let it run for a bit.

Any ideas and suggestions would be greatly appreciated.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Just checked and it all looks good. Even the original plastic wire wrap is in good shape. What's your ideas on this...? Rubbing?
Heat damage?
 
1 - 3 of 3 Posts
Top