Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1441 - 1460 of 1496 Posts

·
Registered
Joined
·
1,849 Posts
Discussion Starter · #1,441 ·
No, 25 months, been probably 3 yrs or so since I got them

Sent from my VS996 using Tapatalk
 

·
Registered
Joined
·
1,849 Posts
Discussion Starter · #1,442 ·
Well here's the problem.
0514211437.jpg
 
  • Like
Reactions: 1TRIKHD

·
Registered
Joined
·
1,849 Posts
Discussion Starter · #1,443 ·
Well injector fixed it but didn't last but a couple pulls. Was a decent hard pull, something popped and now I have fuel everywhere in the stock cp3 location. Almost thinking factory pump let go, what a coincidence. Add another to help it out and it shits out

Sent from my VS996 using Tapatalk
 
  • Like
Reactions: 1TRIKHD

·
Registered
Joined
·
19,240 Posts
Well injector fixed it but didn't last but a couple pulls. Was a decent hard pull, something popped and now I have fuel everywhere in the stock cp3 location. Almost thinking factory pump let go, what a coincidence. Add another to help it out and it shits out

Sent from my VS996 using Tapatalk
Dang that sucks Zach!

Sent from my LM-G900 using Tapatalk
 

·
Registered
Joined
·
1,849 Posts
Discussion Starter · #1,445 ·
Ya, I'm pretty fuckin over it right now. A guy could hope for HP line issue, but I doubt it, 26k to 0 pretty much instantly. When the pumps go do they normally puke fuel? I guess I don't even know the internals of them to know if they'd "throw a of rod" out the case

Sent from my VS996 using Tapatalk
 

·
Registered
Joined
·
19,240 Posts
Ya, I'm pretty fuckin over it right now. A guy could hope for HP line issue, but I doubt it, 26k to 0 pretty much instantly. When the pumps go do they normally puke fuel? I guess I don't even know the internals of them to know if they'd "throw a of rod" out the case

Sent from my VS996 using Tapatalk
I dont know the internals, but 26k to 0 instantly you think its would of blow something off the back of it

Sent from my LM-G900 using Tapatalk
 

·
Registered
Joined
·
19,240 Posts
Maybe a seal blew or the inspection plug?

Sent from my LM-G900 using Tapatalk
 

·
Registered
Joined
·
1,849 Posts
Discussion Starter · #1,448 ·
Thats what I'm hoping for

Sent from my VS996 using Tapatalk
 

·
Registered
Joined
·
1,849 Posts
Discussion Starter · #1,449 ·
Going to tear into truck tomorrow. I've been reading and watching vids and im thinking more and more that its just a HP line issue. S&S has a good video about internals. Say its very unlikely for a catastrophic failure and if so very unlikely that any metal would go through system

Sent from my VS996 using Tapatalk
 

·
Registered
Joined
·
1,849 Posts
Discussion Starter · #1,450 · (Edited)
Turns out it is a hardline issue. #2 inj line blew out...going to order a stainless set from dmaxstore. These were semi cheap lines, get what you pay for
0516211236.jpg
 

·
Registered
Joined
·
1,849 Posts
Discussion Starter · #1,451 ·
Well, I think its time to go with some exergy injectors. Seems like the rest of injectors are starting to leak. The truck is def not running all that great and I have a good bit of fuel leaks going on, enough that my tailgate has diesel all over it. All seeping from hold down area. I guess the lincoln diesel injectors are cheaper for a reason. I'm willing to bet they are all starting to leak from that ball area like inj #4 did.

Sent from my VS996 using Tapatalk
 

·
Registered
Joined
·
19,240 Posts
Well, I think its time to go with some exergy injectors. Seems like the rest of injectors are starting to leak. The truck is def not running all that great and I have a good bit of fuel leaks going on, enough that my tailgate has diesel all over it. All seeping from hold down area. I guess the lincoln diesel injectors are cheaper for a reason. I'm willing to bet they are all starting to leak from that ball area like inj #4 did.

Sent from my VS996 using Tapatalk
How big Zach 100? 150's

Sent from my LM-G900 using Tapatalk
 

·
Registered
Joined
·
1,849 Posts
Discussion Starter · #1,453 ·
Sorry russ, didn't see your reply. Ordered 150s today.....Here's how stupid my injector problem is with that ball popping out... Talked to randy at exergy and he gave me the low down. That ball that is pushing out and leaking is actually on the return side, not pressure side. (Would have been nice to be made aware of that when I replaced 4) So adding the 2nd cp3 to the factory lil return line is building too much pressure.... Pretty dumb reason to have to replace injectors but whatever. I'm going to run a new return line for each pump and y them together so only injectors will be on the factory return line. Pain in the ass now, but will be so worth it when I got them 150s in and no more leak issues

Sent from my VS996 using Tapatalk
 
  • Like
Reactions: 1TRIKHD

·
Registered
Joined
·
1,849 Posts
Discussion Starter · #1,454 ·
Randy told me an "inside secret", on pull trucks they have actually disassembled the injector, hammered the ball back in and tig welded it shut . Absolute worse case I'll have to do that but I think getting the cp3s on their own return will solve the problem

Sent from my VS996 using Tapatalk
 

·
Registered
Joined
·
1,849 Posts
Discussion Starter · #1,455 ·
Got the new sticks!!
0621211513_HDR.jpg
 
  • Like
Reactions: 1TRIKHD

·
Registered
Joined
·
19,240 Posts
Whens the install Zach?

Sent from my LM-G900 using Tapatalk
 

·
Registered
Joined
·
1,849 Posts
Discussion Starter · #1,457 ·
Just finished the easy side, will do the driver side after work tomorrow. Can't wait to have my truck back!!!

Sent from my VS996 using Tapatalk
 

·
Registered
Joined
·
19,240 Posts
Just finished the easy side, will do the driver side after work tomorrow. Can't wait to have my truck back!!!

Sent from my VS996 using Tapatalk
I hear ya on that Zach. Lol

Sent from my LM-G900 using Tapatalk
 

·
Registered
Joined
·
1,849 Posts
Discussion Starter · #1,459 ·
Injectors are in, the infamous p0708 code came back and would not go away, so didnt even really get to hog on it. Cleaned the nsbu and trans plug and blew the piss out of them, they had fuel in them, but still wouldn't go away. So put it in neutral, cleared the codes and was able to keep the code away until I put it in park but it still wasn't quite right. It was shifting weird so just putted around on tune 3. No leaks, so theres that

Sent from my VS996 using Tapatalk
 

·
Registered
Joined
·
1,849 Posts
Discussion Starter · #1,460 ·
Sprayed the piss of the plugs again with brake cleaner, dielectric greased and plugged back in, still was goofy this morning. Late afternoon I fired it up to pull it forward to wash engine bay out and it magically was fixed. So got to beat on it a lil bit. Violent, would be the best word to describe it . Hits hard when that turbo lights. It is def shifting completely different. Even after some good miles to get everything in sync. Seems to just hammer through the gears when I'm casually driving. May have to do some trans tuning or maybe has to learn more. I've only made a few lil hits with tune 4. Terrified to get on it and mess something else up. Hit 27k rail pressure and no leaks whatsoever so think I'll be good, just got to build the confidence back up. Local NWDC event is this weekend so should be finally getting it on the dyno

Sent from my VS996 using Tapatalk
 
1441 - 1460 of 1496 Posts
Top