Chevy and GMC Duramax Diesel Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hey guys I’m looking for some help with the wiring on my current project. Truck is a 2004.5 lly. Had some issues with the stock trans and ended up finding a great deal on a zf6. I’ve got the trans swap completely done but ran into some issues with the wiring. I found that 90 percent of the wires coming out of the tcm went strait to the transmission and I removed all those. I traced back the remaining wires and de pinned them from their connectors. I then added two pins to the ecm connectors for the clutch start switch and two more wires for the speedometer following the wiring diagrams on all data. I flashed the ecu with the zf6 os abs this is where the problems started. As soon as I turn the key the truck says reduced engine power. Trying to start the truck does nothing but that could be because my clutch switch wiring is not hooked up correctly. I left the key in the run position and jumped the terminals on the starter to start the truck. It does start but runs very rough like it’s trying to shake itself apart. Fuel pressure increases to max then drops back down and just keeps doing that. Everything in the cab works as it should. I also swapped out the factory push button 4x4 for a manual shift and that is all working. All gauges seem to work except the oil pressure gauge. I pulled the codes with my auto cal and got “U1000 Class 2 Communication Malfunction” from the bcm and climate controls plus every possible code to do with the throttle pedal but I don’t remember them offhand (I’ll update when I get home). Seems to me like I must have messed up something with the wiring. So far I’ve disconnected the batteries and let it sit for awhile, tried clearing the codes, and checked the ecm connectors for pins not fully seated or in the wrong place all with no change. Any help would be greatly appreciated.
 

·
Former GM Tech and parts
Joined
·
2,941 Posts
I've not done the swap- was interested in it many years ago, but never did pursue it. I'm pretty sure there was a guy here that did it on his truck, and had written in a thread about what his wiring changes consisted of- and I'm thinking they were no where near as in-depth as yours. It may take some time and investigating, but I would look into the ZF section and see if you can find it.
 

·
Former GM Tech and parts
Joined
·
2,941 Posts
ZF6 swap done..

This is actually the main post I was talking about. Not sure if he's still involved on the forum anymore, but this guys posts can probably give you some direction
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Thanks for the reply, I actually found that thread in my research before I started the swap. He kept his ecu thinking it was an auto and left all the wiring so he didn't run into any of these problems. My goal with my swap was to make it as factory as possible. Hence removing all the wiring for the auto which seems to have come back to bite me in the ass lol.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Just got home and plugged my scanner back in codes are as follows
Pcm P1125
Pcm P2122
Pcm P2133
Bcm U1000
Sdm U1000
Hvac U1000
Ddm U1016

Seems to me like everything in the interior can't talk to the ecm? Not sure whats up with the throttle all wiring for that looks good. Thanks for the help guys.
 

·
Registered
Joined
·
20,589 Posts
ZF6 swap done..

This is actually the main post I was talking about. Not sure if he's still involved on the forum anymore, but this guys posts can probably give you some direction
hes been gone since 2013 unfortunately Matt

he was one of the OG’s
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Alright I figured out the issue I was having. When I was repining ecu connectors I must have pulled on a couple of the wires to hard. I had my buddy who got much better eyes then me take a look and he saw a few pins pushed back too far. After resetting them all the truck starts and runs!
 
1 - 8 of 8 Posts
Top